Blocking of privilege "GUILD_MEMBERS" by privileged Gateway Intents verifiers.
Incident Report for EspCustoms
Resolved
✅Approved the privileged intent of "Guild_Members" and restoration of detection in events, the update has been uploaded and its behavior in tests is correct.👍🏽
Posted Jan 18, 2024 - 22:57 CET
Monitoring
Privilege blocking "GUILD_MEMBERS" by the Gateway Intents privilege checkers, I have made several privilege checks but still not activated for the bot, which has led me to have to make small modifications for some systems that have the bot, now the welcomes (images and messages) will be given when the user writes any message for the first time in the server, because as you know it tracks if the author of the new message is in the database or not and if not it emits the welcome event, I will continue sending verification to be able to have the privilege of "GUILD_MEMBERS" and to detect them.
Posted Jan 15, 2024 - 18:51 CET
This incident affected: ESP CUSTOMS (API + BOT, DASHBOARD).